Implementasi VTP Server, VTP Client, dan DHCP Server pada jaringan WAN

Dalam sebuah jaringan WAN Universitas X mempunyai gedung dengan 3 lantai di dalamnya. Kemudian terdapat beberapa komputer yang dipergunakan oleh staff pekerja, asumsikan satu lantai mempunyai jumlah 250an komputer. Seorang kepala gedung berharap tiap – tiap gedung hanya komputer sama lantai sajalah yang dapat berkomunikasi. Apakah yang dapat administrator gedung selesaikan untuk mengatasi kasus yang dimiliki kepala gedung?

Penyelesaian :
Administrator sudah memiliki DHCP Server ( Mikrotik RB1100AH), VTP Server (Nexus N7000K), VTP Client ( DSW 3750SX).
Daftar IP Address
IP > 10.11.6.0/24 > ID VLAN >26
IP > 10.11.7.0/24 > ID VLAN >27
IP > 10.11.8.0/24 > ID VLAN >28
Untuk interface DHCP Server menuju ke VTP Server mode trunk, kemudian interface VTP Server ke VTP Client  mode trunk, selanjutnya VTP Client ke end user memiliki perlakuan berbeda yaitu mode access vlan.

01-04-02-2014-vtp cisco dhcp mikrotik

Untuk konfigurasi Cisco penulis tidak menjelaskan dari awal, dikarenakan pembaca berharap sudah bisa dan mahir dalam konfigurasi basic Cisco SBA .🙂

Step 1. VTP Server
Berikut command untuk konfigurasi cisco vtp server. VTP Server memungkinkan perangkat menyimpan databases vlan id yang akan didistribusikan ke dalam vtp client.

VTP-Server>enable
VTP-Server#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
VTP-Server(config)#hostname VTP-Server
VTP-Server(config)#vtp mode server 
Device mode already VTP SERVER.
VTP-Server(config)#vlan 26
VTP-Server(config-vlan)#name LT01
VTP-Server(config-vlan)#vlan 27
VTP-Server(config-vlan)#name LT02
VTP-Server(config-vlan)#vlan 28
VTP-Server(config-vlan)#name LT03
VTP-Server(config-vlan)#exit
VTP-Server(config)#exit
VTP-Server#
%SYS-5-CONFIG_I: Configured from console by console
VTP-Server#write
Building configuration...
[OK]

Hasilnya sebagai berikut :

VTP-Server#show vlan brief
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig1/1, Gig1/2
26 LT01 active 
27 LT02 active 
28 LT03 active 
1002 fddi-default active 
1003 token-ring-default active 
1004 fddinet-default active 
1005 trnet-default active 
VTP-Server#

Keterangan :

  • enable > masuk konfig perangkat
  • configure terminal > masuk ke mode secret
  • hostname > merubah hostname perangkat cisco
  • vtp mode server > merubah mode virtual trunking protocol ke mode server
  • vlan [ID]> membuat ID vlan
  • name [nama] > memberikan deskripsi nama vlan
  • write > menuliskan ke ROM memory cisco

Step 2. VTP Client

Langkah berikut dipergunakan untuk mengkonfigurasi vtp client. Ingat, ketika perangkat cisco menggunakan mode vtp client berarti tidak membuat vlan databases sendiri melainkan menerima id database vlan dari vtp server.

Switch>
Switch>enable
Switch#configure terminal 
Switch(config)#hostname VTP-Client
VTP-Client(config)#vtp mode client 
VTP-Client(config)#interface fastEthernet0/6
VTP-Client(config-if)#switchport mode access 
VTP-Client(config-if)#switchport access vlan 26
VTP-Client(config-if)#description "link to LT01"
VTP-Client(config-if)#no shutdown 
VTP-Client(config-if)#exit
VTP-Client(config)#interface fastEthernet 0/7
VTP-Client(config-if)#switchport mode access 
VTP-Client(config-if)#switchport access vlan 27
VTP-Client(config-if)#description "link to LT02"
VTP-Client(config-if)#no shutdown 
VTP-Client(config-if)#exit
VTP-Client(config)#interface fastEthernet 0/8
VTP-Client(config-if)#switchport mode access 
VTP-Client(config-if)#switchport access vlan 28
VTP-Client(config-if)#description "link to LT03"
VTP-Client(config-if)#no shutdown 
VTP-Client(config-if)#exit
VTP-Client(config)#exit
VTP-Client#write
Building configuration...
[OK]
VTP-Client#show running-config

Hasil konfigurasi :

interface FastEthernet0/6
 description "link to LT01"
 switchport access vlan 26
 switchport mode access
!
interface FastEthernet0/7
 description "link to LT02"
 switchport access vlan 27
 switchport mode access
!
interface FastEthernet0/8
 description "link to LT03"
 switchport access vlan 28
 switchport mode access
!

Keterangan :

  • enable > masuk konfig perangkat
  • configure terminal > masuk ke mode secret
  • hostname > merubah hostname perangkat cisco
  • vtp mode client > merubah mode virtual trunking protocol ke mode client untuk menerima distribusi ID vlan
  • interface [nomor port] > masuk ke dalam config interface
  • switchport mode access > memberika izin mode access untuk interface yang sedang diconfig
  • switchport access vlan [id] > memberikan izin akses id vlan mana saja yang dapat berjalan
  • descriptions “” > memberikan komentar descriptions untuk masing konfigurasi
  • no shutdown > mengaktifkan interface  (*no dalam arti memberikan negasi dari pengaturan)
  • write > menuliskan ke ROM memory cisco

Step 3. DHCP Server 

Dalam topologi ini DHCP Server berfungsi untuk mendistribusikan ip address yang ada pada jaringan public ke jaringan – jaringan end user di masing – masing tiap gedung. Hardware yang mendukung adalah Mikrotik RB1100 AH dengan 2 CPU dan RAM 2 GB. Untuk menkonfigurasi device menggunakan Winbox 2.26
Berikut langkah – langkahnya :

  1. Buka aplikasi winbox
    02-04-02-2014-vtp cisco dhcp mikrotik
    Ketikan IP address dhcp server, kemudian isikan username dan password selanjutnya klik Connect
  2. Apabila sudah masuk ke desktop mikrotik, langkah awalnya yaitu membuat interface VLAN. ( asumsikan interface yang menuju vtp server adalah Ether 3 Mikrotik)
    Klik Interface > Add VLAN
    03-04-02-2014-vtp cisco dhcp mikrotik
    Maka muncul jendela seperti berikut :
    04-04-02-2014-vtp cisco dhcp mikrotik
    Dari menu, silahkan isikan nama Interface VLAN. Perlu diperhatikan kemudian jangan lupa ID VLAN, dan Interface yang menuju ke VTP Server.
  3. Selanjutnya user harus menngisikan ip address vlan yang telah kita buat tadi.
    Klik IP > Address
    06-04-02-2014-vtp cisco dhcp mikrotik

    Kemudian isikan ip address dan interfacenya (berikan ip address terakhir dalam network pembagian tiap lantai)
    05-04-02-2014-vtp cisco dhcp mikrotik
    Jika sudah Klik OK
  4. Selanjutnya membuat DHCP Server
    Klik IP > DHCP Server
    maka akan muncul jendela seperti gambar berikut
    07-04-02-2014-vtp cisco dhcp mikrotik
    Kemudian akan muncul jedela DHCP Server list
    08-04-02-2014-vtp cisco dhcp mikrotik
    Untuk membuat DHCP Server langsung saja klik DHCP Setup
    Ketika pilihan interface, maka pilih interface VLAN
    09-04-02-2014-vtp cisco dhcp mikrotik
    Next, kemudian network address yang tersedia
    10-04-02-2014-vtp cisco dhcp mikrotik
    Next, kemudian mengisikan gateway
    11-04-02-2014-vtp cisco dhcp mikrotik
    Next, range ip address yang didistribusikan
    12-04-02-2014-vtp cisco dhcp mikrotik
    Next, kemudian mengisikan DNS yang akan dipakai
    13-04-02-2014-vtp cisco dhcp mikrotik
    Next, selanjutnya mengisikan leased time
    14-04-02-2014-vtp cisco dhcp mikrotik
    Next, maka muncul notifikasi DHCP Server telah selesai dibuat.
    15-04-02-2014-vtp cisco dhcp mikrotik

    **Lakukan hal yang sama untuk VLAN ID 27 dan VLAN ID 28 dengan ip network sesuai ketentuan**

Sekian, :)Referensi :
http://www.cisco.com/en/US/tech/tk389/tk689/technologies_configuration_example09186a0080890607.shtml
http://www.cisco.com/en/US/tech/tk389/tk689/technologies_tech_note09186a0080094c52.shtml
http://wiki.mikrotik.com/wiki/Manual:Interface/VLAN
http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server

2 thoughts on “Implementasi VTP Server, VTP Client, dan DHCP Server pada jaringan WAN”

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s